remove stuff we won't need
[pcsx_rearmed.git] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index 8645846..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-#export DH_VERBOSE=1
-
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2 -fomit-frame-pointer
-endif
-
-CONFIGURE_PARAM = \
-       --host=$(DEB_HOST_GNU_TYPE) \
-       --build=$(DEB_BUILD_GNU_TYPE) \
-       --prefix=/usr \
-       --bindir=/usr/games \
-       --mandir=\$${prefix}/share/man \
-       --infodir=\$${prefix}/share/info \
-       --enable-opengl
-
-config.status: configure
-       dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure $(CONFIGURE_PARAM)
-
-build: build-stamp
-
-build-stamp: config.status
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       [ ! -f Makefile ] || make distclean
-
-       dh_clean config.status config.log po/stamp-po
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_installdirs
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/pcsxr
-       # Remove useless files
-       rm -f $(CURDIR)/debian/pcsxr/usr/lib/games/psemu/*.la
-
-binary-indep: build install
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs ChangeLog
-       dh_installdocs
-       dh_installmenu
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_makeshlibs
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install