tune the preloads a bit
[sdl_omap.git] / SDL.spec
1 Summary: Simple DirectMedia Layer
2 Name: SDL
3 Version: 1.2.14
4 Release: 1
5 Source: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
6 URL: http://www.libsdl.org/
7 License: LGPL
8 Group: System Environment/Libraries
9 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
10 Prefix: %{_prefix}
11 %ifos linux
12 Provides: libSDL-1.2.so.0
13 %endif
14
15 %define __defattr %defattr(-,root,root)
16 %define __soext so
17
18 %description
19 This is the Simple DirectMedia Layer, a generic API that provides low
20 level access to audio, keyboard, mouse, and display framebuffer across
21 multiple platforms.
22
23 %package devel
24 Summary: Libraries, includes and more to develop SDL applications.
25 Group: Development/Libraries
26 Requires: %{name} = %{version}
27
28 %description devel
29 This is the Simple DirectMedia Layer, a generic API that provides low
30 level access to audio, keyboard, mouse, and display framebuffer across
31 multiple platforms.
32
33 This is the libraries, include files and other resources you can use
34 to develop SDL applications.
35
36
37 %prep
38 %setup -q 
39
40 %build
41 %ifos linux
42 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} --disable-video-aalib --disable-video-directfb --disable-video-ggi --disable-video-svga
43 %else
44 %configure
45 %endif
46 make
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %ifos linux
51 make install prefix=$RPM_BUILD_ROOT%{prefix} \
52              bindir=$RPM_BUILD_ROOT%{_bindir} \
53              libdir=$RPM_BUILD_ROOT%{_libdir} \
54              includedir=$RPM_BUILD_ROOT%{_includedir} \
55              datadir=$RPM_BUILD_ROOT%{_datadir} \
56              mandir=$RPM_BUILD_ROOT%{_mandir}
57 ln -s libSDL-1.2.so.0 $RPM_BUILD_ROOT%{_libdir}/libSDL-1.1.so.0
58 %else
59 %makeinstall
60 %endif
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %{__defattr}
67 %doc README-SDL.txt COPYING CREDITS BUGS
68 %{_libdir}/lib*.%{__soext}.*
69
70 %files devel
71 %{__defattr}
72 %doc README README-SDL.txt COPYING CREDITS BUGS WhatsNew docs.html
73 %doc docs/index.html docs/html
74 %{_bindir}/*-config
75 %{_libdir}/lib*.a
76 %{_libdir}/lib*.la
77 %{_libdir}/lib*.%{__soext}
78 %dir %{_includedir}/SDL
79 %{_includedir}/SDL/*.h
80 %{_libdir}/pkgconfig/sdl.pc
81 %{_datadir}/aclocal/*
82 %{_mandir}/man3/*
83
84 %changelog
85 * Tue May 16 2006 Sam Lantinga <slouken@libsdl.org>
86 - Removed support for Darwin, due to build problems on ps2linux
87
88 * Mon Jan 03 2004 Anders Bjorklund <afb@algonet.se>
89 - Added support for Darwin, updated spec file
90
91 * Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
92 - Re-integrated spec file into SDL distribution
93 - 'name' and 'version' come from configure 
94 - Some of the documentation is devel specific
95 - Removed SMP support from %build - it doesn't work with libtool anyway
96
97 * Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
98 - Hacked Mandrake sdl spec to build 1.1
99
100 * Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
101 - Build Release
102
103 * Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
104 - Add symlink for libSDL-1.0.so.0 required by sdlbomber
105 - Added docs
106
107 * Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
108 - v 1.0.0
109
110 * Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
111 - First spec file for Mandrake distribution.
112
113 # end of file